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Using the Cute
Rich-Text Editor

This document is designed to provide users with a basic introduction to using the Cute rich-text
editor to format text, create and modify tables, and to place charts and graphs into IEPWriter.
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Figure 1: Cute rich-text editor toolbar and text box
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Formatting Text

There are two methods to format text:
e Format the text after entering all desired text in the textbox (preferred method),

Tip:  After you have entered all desired text in the text box, select all of the text, then
select Erase Formatting. This will remove any existing formatting, at which point
you can select your desired font type, size etc. to affect all text within the textbox.

e Select a formatting type (such as bold or italics) before or as you enter text in the textbox. In this
case, the formatting you selected will be retained until you press the Enter key. At that point, any
new text you enter will default back to “normal” type.

Note for Internet Explorer users

All unformatted text will print in the font Courier New, even though the default font is Times New
Roman.

Tips for Creating Text in Microsoft Word

o If multiple users will paste text into IEPWriter’s textboxes for a student, they should use the same
font when entering text in Word.

e When pasting text from Word into an IEPWriter textbox, click the Paste from Word button. This
removes much of Word’s extraneous formatting.

Tips for Creating Tables in Microsoft Word

Note: For best results, it is recommended that you create tables directly in IEPWriter
rather than copy them from Microsoft Word and paste them into IEPWriter.

To ensure a table displays and prints properly when copied from Word and pasted into an IEPWriter
textbox, do the following in Word:

e Ensure that the table is no wider than roughly 2/3 of the page.
e Do not include rows that span multiple columns.

Tlp on Copying and Pasting Text within IEPWriter

Do not copy text in IEPWriter unless it is within a textbox. If you do, it will not paste properly.

e When copying text from the Audit Tracking area to be pasted into a textbox (you get to the Audit
Tracking area by clicking the magnifying glass icon), be sure to copy only the text within the cell.
If you inadvertently copy the lines around the table, the lines will also be pasted into the textbox.
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Creating Tables in IEPWriter

Using Firefox 2.0 and 3.0

To create a table:
1. Navigate to the desired text box and click the Table icon on the Cute rich-text editor toolbar.
2. The Insert Table dialog box displays. Select your preferences.

Note: The default options will create a table with two columns and two rows.

3. Click OK.

To add text to a table:
Place the cursor in a cell and begin typing.

Note: The table will automatically adjust to fit the text in each cell as you type.

To move from cell to cell, do any of the following:
e Press Tab to move forward in cells.
or
e Use the arrow keys to move in multiple directions from cell to cell.
or
e Click in the desired cell.

To resize a table:
1. Click on the table to display sizing handles around its perimeter.
2. Place the cursor over a sizing handle, then click and drag to the desired size.

To modify a table:
1. Click on the border of the table you want to modify.
2. Click the Modify Table icon on the Cute rich-text editor toolbar.
3. The Insert Table dialog box displays. Select your new preferences.
4. Click OK.

To add columns to a table:
Using the toolbar
1. Click the desired cell within the table.
2. Click either the Insert Column to the Left icon or the Insert Column to the Right icon on the
Cute rich-text editor toolbar.

Using the mouse:
1. Clickinacell.
2. Horizontal and vertical arrow markers display in the cell’s outline.
e Click the left arrow to add a column to the left of the current column.

e Click the right arrow to add a column to the right of the current column.

To change the outline of a table:
When adding a row or column by pressing Tab or clicking an add column/add row arrow, it has a solid
outline. To give it a dashed line:

1. Click the Modify Table icon on the Cute rich-text editor toolbar.

2. The Insert Table dialog box displays. Click OK.
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To add rows to a table:
Using the toolbar:
1. Click the desired cell within the table.
2. Click either the Insert Row Above icon or the Insert Row Below icon on the Cute rich-text
editor toolbar.

Using the keyboard:
Place the cursor in the last cell of the bottom row and press Tab.

Using the mouse:
1. Clickin acell.
2. Horizontal and vertical arrow markers display in the cell’s outline.
e Click the up arrow to add a row above the current row.
e Click the down arrow to add a row below the current row.

To delete a column:
Using the mouse:
Click the X between the horizontal arrows.

Using the toolbar:
1. Clickin a cell located in the column you want to delete (the cursor must be placed in a cell with
text).
2. Click the Delete Columns icon on the Cute rich-text editor toolbar.

To delete arow:
Using the mouse:
Click the X between the vertical arrows.

Using the toolbar:
1. Clickin a cell located in the row you want to delete.
2. Click the Delete Rows icon on the Cute rich-text editor toolbar.

To delete atable:
Click each X between the horizontal or vertical arrows until the table is gone.

Using Internet Explorer 6.0 or 7.0

To create a table:
1. Navigate to the desired text box and click the Insert Table icon on the Cute rich-text editor
toolbar.
2. A drop-down menu displays. Select the number of rows and columns you want your table to
have.

Note: The default options will create a table with two columns and two rows. You
may select up to 6 columns and 4 rows.

3. Click OK.

To add text to a table:
Place the cursor in a cell and begin typing.
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\Note: The table will automatically adjust to fit the text in each cell as you type.

To move from cell to cell, do one of the following:
e Use the arrow keys to move in multiple directions from cell to cell.
or
e Click in each cell.

To resize a table:
1. Click on the perimeter of the table to display its sizing handles.
2. Place the cursor over a sizing handle, then click and drag to the desired size.

To modify a table:
1. Double-click the border of the table you want to modify.
2. The Table Properties dialog box displays with three tabs in the upper-left corner to help you
select your preferences. (In version 6.0, the Table Properties dialog box displays, but without
the three tabs. Select your preferences, and skip to step 3).
e The Table Wizard tab displays general table properties. For instructions on how to add,
delete or modify rows and columns, see below.
e The Table tab allows you to select border and background settings as well as other
advanced options. (for specific instructions on how to change border options, see below)
e The Common tab allows you to select more advanced options.
3. When finished selecting your preferences, click OK.

To add columns to a table:
1. Click the desired cell within the table.
2. Click either the Insert Column to the Left icon or the Insert Column to the Right icon on the
Cute rich-text editor toolbar.

To add rows to a table:
1. Click the desired cell within the table.
2. Click either the Insert Row Above icon or the Insert Row Below icon on the Cute rich-text
editor toolbar.

To delete a column:
1. Place the cursor in a cell located in the column you want to delete.
2. Click the Delete Columns icon on the Cute rich-text editor toolbar.

To delete arow:
1. Place the cursor in a cell located in the row you want to delete.
2. Click the Delete Rows icon on the Cute rich-text editor toolbar.

To delete a table:
1. Click on the perimeter of the table to display sizing handles.
2. Press Delete or right-click and select Delete.

To add a border to your table:
1. Double-click the border of the table you want to modify.
2. The Table Properties dialog box displays with three tabs in the upper left corner to help you
select your preferences. (In version 6.0, the Table Properties dialog box displays, but without
the three tabs. Select your preferences, and skip to step 5).
3. Click on the Table tab to bring up the table properties menu.
4. In the Border box change the numeric value from 0 to 1.
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5. Click OK.

Note: When changing the border setting on a table, the border will NOT be
displayed on your computer screen. The changes will take effect when
printing the document.

Using Safari 1.3, 2, or 3

To create a table:
1. Navigate to the desired text box and click within it.
2. Click the Table icon on the Cute rich-text editor toolbar.
3. The Insert Table dialog box displays. Select your preferences.

Note: The default options will create a table with one column and one row. You
may select up to 15 columns and 15 rows.

4. Click OK.

To add text to a table:
Place the cursor in a cell and begin typing.

Note: The table will automatically adjust to fit the text in each cell as you type.

To move from cell to cell:
e Place the cursor in the cell and use the down arrow key to move forward; use the up arrow key
to move backward, or

e Click in the desired cell.

To delete arow:
1. Highlight all the cells within a row.
2. Press the Backward Delete key and the text within the table clears.

To delete atable:
1. Highlight all the cells within the table.
2. Press the Backward Delete key.

Additional notes about creating tables in Safari 2.0
e Tables cannot be resized or modified.
e You cannot add columns or rows once a table is created.
e You cannot delete columns.

Tips on Tables in IEPWriter

¢ Designate the number of columns and rows for the table before entering data.

Note for Internet Explorer users:
To ensure the lines from a table display on IEPWriter screens, double-click on an
intersection within the table in the textbox. A dialog box displays; enter the
number "1" in the Border field.
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Placing a chart or graph
into IEPWriter using Cute

Charts and graphs cannot be copied and pasted into text boxes when using Cute. Instead, they must
be uploaded into IEPWriter.

These instructions are for users of Windows-based computers, as they come with image-editing
software called Paint. If you do not have Paint, you can use third-party image-editing software; save
the image file as a .jpg or .jpeg before uploading the file in IEPWriter. At this time, Macintosh
computers do not have a default image editor. You may, however, use a screen-capture technique to
copy an image onto your screen and convert it to an appropriate file format, as outlined here:

Note: If you are using a Windows-based computer, skip to the next section, To copy
your chart or graph into IEPWriter using Paint.

Graphic conversion for images on a Macintosh computer

Open the item you want to save as a jpeg.

Click Hard Drive—> Applications—> Utilities=> Grab—> minimize.

Click Capture—> Selection. Drag over the item you want to capture.

Go to File> Save as.

Save the file as a .tiff.

Open the .tiff file and click File=> Save as, and change the format from .tiff to .jpeg. Click Save.
Bring the file into IEPWriter by clicking on Insert Image-> Browse-> [find .jpeg file] > Upload—>
Insert.

NouokrwbE

To copy your chart or graph into IEPWriter using Paint:

Copy the image.

Click the Windows Start Menu.

Click All Programs—> Accessories—> Paint.

Click Edit-> Paste to paste the image into the Paint window.

Click File> Save As.

Navigate to the desired folder to save the file.

Type a file name (the file name must contain no spaces or special characters) and select
JPEG as the file type.

Click Save.

In IEPWriter, navigate to the text box where you want to insert the chart or graph. On the Cute
rich-text editor toolbar, click the Insert Image icon.

10. The Insert Image dialog box
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Figure 2: Insert Image dialog box
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11. Click the name of the file.

12. Click Open.

13. Click upload.

14. When the message (name of image) uploaded successfully! displays, click Insert.
15. The image displays in the text box.

To resize the image in IEPWriter
1. Click the image in the text box to display the sizing handles around its perimeter.
2. Place the cursor over a sizing handle then click and drag to the desired size.
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